1 | -*-*- END -*-*-
|
---|
2 | 2000/03/01: Thomas Bretz
|
---|
3 |
|
---|
4 | * manalysis/Makefile, mdatacheck/Makefile, meventdisp/Makefile,
|
---|
5 | mgui/Makefile:
|
---|
6 | new
|
---|
7 |
|
---|
8 | * mdatacheck/MFillAdcSpect.[h,cc]:
|
---|
9 | changed high and low to hi and lo
|
---|
10 |
|
---|
11 | * mdatacheck/MGDisplayAdc.[h,cc]:
|
---|
12 | added some new member functions to make code more clear
|
---|
13 |
|
---|
14 | * mdatacheck/MHistosAdc.h:
|
---|
15 | changed high and low to hi and lo
|
---|
16 |
|
---|
17 |
|
---|
18 | 2000/03/01: Thomas Bretz
|
---|
19 |
|
---|
20 | * Makefile: added headers to dependencies
|
---|
21 |
|
---|
22 | * Makefile.rules: added headers to dependencies
|
---|
23 |
|
---|
24 | * merpp.cc: changed from pointers to objects, added compression level
|
---|
25 |
|
---|
26 | * readraw.cc: removed unnecessary includes
|
---|
27 |
|
---|
28 | * mbase/MArray*.*: changed all Int_t to UInt_t
|
---|
29 |
|
---|
30 | * mbase/MLogManip.h: changed name of __DINF__ to dbginf
|
---|
31 |
|
---|
32 | * mraw/MRawCrateData.[h,cc]: changed ifstream to istream
|
---|
33 | * mraw/MRawEvtHeader.[h,cc]: dito
|
---|
34 | * mraw/MRawRunHeader.[h,cc]: dito
|
---|
35 |
|
---|
36 | * mraw/MRawEvtData.cc: changed the reading, which speeds up merpp by
|
---|
37 | a factor of 10
|
---|
38 |
|
---|
39 | * mraw/MRawEvtData.h: added flag to InitArrays and DeletePixels
|
---|
40 | (not yet used)
|
---|
41 |
|
---|
42 | * mraw/MRawFileRead.h: removed pParList from parameter list
|
---|
43 |
|
---|
44 | * manalysis/AnalysisLinkDef.h
|
---|
45 | removed MReadCT1Ascii, added MCT1ReadAscii
|
---|
46 | added MCT1Pedestals
|
---|
47 |
|
---|
48 | * manalysis/MCerPhotEvt.[h,cc]:
|
---|
49 | changed the constructor a little bit, rewrote Print() to make it
|
---|
50 | a bit more readable, moved MCerphotPix to new File, added many lines
|
---|
51 | of comments, exchanged old stylish new call with new stylish(=) one,
|
---|
52 | replaced all accesses to fPixels with the [] operator to make this
|
---|
53 | lines more readable, made all variable declarations const-correct,
|
---|
54 | I changed the style of the cleaning method from if(a){if()b{if(c){}}}
|
---|
55 | to if(!a)continue; if(!b)continue if(!c) continue; to make it more
|
---|
56 | compact, readable and easier to understand, renamed the Boolean-
|
---|
57 | functions to Is* to get a stricter structure, replaced mapping
|
---|
58 | function to access the pixel list entries by the new operator to
|
---|
59 | get rid of more than the necessary number of member functions without
|
---|
60 | loosing speed or readability, renamed GetMinimum/MaximumPhoton to
|
---|
61 | GetMin/MaxNumPhotons to be more exact
|
---|
62 |
|
---|
63 | * mgui/MCamGeom.* splitted and changed to MGeomCam/Pix:
|
---|
64 | added a new operator to access the TObjArray, removed unnecessary
|
---|
65 | code from CreateCT1
|
---|
66 |
|
---|
67 | * mbase/MAGIC.h: added kPI
|
---|
68 |
|
---|
69 | * mbase/MReadTree.cc: added some comments
|
---|
70 |
|
---|
71 | * mgui/MCamDisplay.[h,cc]:
|
---|
72 | added some comments, reordered a bit the calls in the constructor
|
---|
73 | to get a 'straight forward structure', MGeomCam is now only
|
---|
74 | locally used where it is needed, replaced access to the
|
---|
75 | TClonesArrays by new member-function to get a more readable code,
|
---|
76 | replaced old stylish new call with new stylish one, made
|
---|
77 | variable decleration const-correct, introduced a new member function
|
---|
78 | to set the pixel color, renamed the overloaded Draw functions to
|
---|
79 | DrawPhotons, DrawPhotErr to prevent missunderstatements, changed
|
---|
80 | the 'layout' of GetColor to make it easier to understand the algorithm,
|
---|
81 |
|
---|
82 | * mgui/MCamNeighbor.[h, cc]:
|
---|
83 | changed to new log-interface, exchanged -9999 by -1, skipped the
|
---|
84 | exits, you must check for -1 one in any case, this means a warning
|
---|
85 | should be enough
|
---|
86 |
|
---|
87 | * mgui/MHexagon.[h,cc]:
|
---|
88 | added new constructor whcih uses a MGeomPix-object,
|
---|
89 |
|
---|
90 |
|
---|
91 | 2000/02/28: Thomas Bretz
|
---|
92 |
|
---|
93 | * mraw/MRawEvtPixelIter.h: added GetSum* functions
|
---|
94 |
|
---|
95 | * mbase/MParList.[h,cc]: changed return type of FindObject back to TObject,
|
---|
96 | it seems so, that some compilers don't like overriding the
|
---|
97 | return type of a virtual member function
|
---|
98 |
|
---|
99 |
|
---|
100 | 2000/02/23: Thomas Bretz
|
---|
101 |
|
---|
102 | * mraw/MRawEvtPixelIter.h: added GetSum* functions
|
---|
103 |
|
---|
104 | * mbase/MParList.[h,cc]: Removed unnecessary fNext-stuff
|
---|
105 |
|
---|
106 |
|
---|
107 | 2000/02/22: Thomas Bretz
|
---|
108 |
|
---|
109 | * merpp.cc, readraw.cc, mbase/MParContainer.cc, mbase/MParList.cc,
|
---|
110 | mbase/MParList.h, mbase/MReadTree.cc, mbase/MTask.cc, mbase/MTask.h,
|
---|
111 | mbase/MTaskList.cc, mbase/MTime.cc, mdatacheck/MDumpEvtHeader.cc,
|
---|
112 | mdatacheck/MShowSpect.cc, meventdisp/MGFadcDisp.cc, mgui/MGPrototyp.h,
|
---|
113 | mmc/MHeaderTrig.cxx, mraw/MRawCrateArray.cc, mraw/MRawEvtData.cc,
|
---|
114 | mraw/MRawEvtHeader.cc, mraw/MRawFileRead.cc, mraw/MRawFileWrite.cc,
|
---|
115 | mraw/MRawRunHeader.cc:
|
---|
116 | exchanged cout with the new logging style (gLog, *fLog)
|
---|
117 | \\ \hline
|
---|
118 | &&&{\em Gesamt:}&{\bfseries 549.00 DM}\\
|
---|
119 | \hline
|
---|
120 |
|
---|
121 | * mraw/MRawEvtData.cc: added 'dec' option to Print
|
---|
122 |
|
---|
123 | * mmc/MHeaderTrig.cxx, mmc/MMcEvt.cxx, mmc/MMcTrig.cxx:
|
---|
124 | small changes to the Print funtions
|
---|
125 |
|
---|
126 |
|
---|
127 | 2000/02/21: Thomas Bretz
|
---|
128 |
|
---|
129 | * MRawEvtData.cc: Changed ReadEvt according to the new
|
---|
130 | raw binary format 2001/02/20
|
---|
131 |
|
---|
132 | * Added MLog.[h,cc], MLogManip.[h,cc]
|
---|
133 |
|
---|
134 | * Adde SetStreamer and fLog to the MParContainer base class
|
---|
135 |
|
---|
136 | * Derived MEvtLoop from MParContainer
|
---|
137 |
|
---|
138 | * Makefile: added 'tar'
|
---|
139 |
|
---|
140 | * mbase/BaseIncl.h: added fstream.h, TGListBox.h
|
---|
141 |
|
---|
142 | * mbase/BaseLinkDef.h: added pragma for gLog and MLog
|
---|
143 |
|
---|
144 | * mbase/MAGIC.h: added forward definition for gLog
|
---|
145 |
|
---|
146 | * mbase/MEvtLoop.cc: exchanged cout with *fLog, added statements
|
---|
147 | to provide log-facility to all tasks als parameter containers
|
---|
148 |
|
---|
149 | * mbase/MEvtLoop.h: Small changes
|
---|
150 |
|
---|
151 | * mbase/MParContainer.h: Added definitions necessary for use of Log-Facility
|
---|
152 |
|
---|
153 | * mbase/MParList.[h,cc]: Added SetLogStream
|
---|
154 |
|
---|
155 | * mbase/MTask.h: added fLog
|
---|
156 |
|
---|
157 | * mbase/MTaskList.[h,cc]: added SetLogStream
|
---|
158 |
|
---|
159 | * mbase/Makefile: Added MLog.cc, MLogManip.cc
|
---|
160 |
|
---|
161 |
|
---|
162 | 2000/02/19: Harald Kornmayer
|
---|
163 |
|
---|
164 | * implemented the Image Cleaning a la CT1 to the class MCerPhotEvt
|
---|
165 |
|
---|
166 | * changed the readCT1.C file to show the effects of the image cleaning
|
---|
167 | a la CT1
|
---|
168 |
|
---|
169 | * changed
|
---|
170 | mgui/MCamNeighbor.cc
|
---|
171 | mananlysis/MCerPhotEvt.cc .h
|
---|
172 | macros/readCT1.C
|
---|
173 |
|
---|
174 |
|
---|
175 | 2000/02/19: Thomas Bretz
|
---|
176 |
|
---|
177 | * MParContainer.h added prototypes for AsciiRead/Write
|
---|
178 |
|
---|
179 | * .rootrc: added
|
---|
180 |
|
---|
181 | * MEvtLoop.[h,cc]: split eventloop in its three parts, this should
|
---|
182 | be used for debugging only.
|
---|
183 |
|
---|
184 |
|
---|
185 | 2000/02/06: Harald Kornmayer
|
---|
186 |
|
---|
187 | * the first running version with a eventdisplay. Now we are able
|
---|
188 | to display an Event on the photo electron level. To do this, run
|
---|
189 | the macro "macros/readCT1.C" after changing the file name.
|
---|
190 |
|
---|
191 | changed:
|
---|
192 | macros/readCT1.C
|
---|
193 | manalysis/MNphotEvent.cc, manalysis/MNphotEvent.h
|
---|
194 | analysis/MReadCT1Ascii.cc
|
---|
195 | mgui/MCamDisplay.cc, mgui/MCamDisplay.h
|
---|
196 |
|
---|
197 |
|
---|
198 | 2000/01/23: Harald Kornmayer
|
---|
199 |
|
---|
200 | * the integration of the class FadcDisp in the mars enviroment
|
---|
201 | and further developments in the display
|
---|
202 |
|
---|
203 | changed:
|
---|
204 | meventdisp/MGFadcDisp.h
|
---|
205 | meventdisp/MGFadcDisp.cc
|
---|
206 | mgui/GuiIncl.h
|
---|
207 | mgui/GuiLinkDef.h
|
---|
208 | mgui/MGMarsMain.cc
|
---|
209 | mgui/MGPrototyp.cc
|
---|
210 | mgui/MGPrototyp.h
|
---|
211 | mgui/Makefile
|
---|
212 |
|
---|
213 | added:
|
---|
214 | mgui/MGEventDispMain.h
|
---|
215 | mgui/MGEventDispMain.cc
|
---|
216 |
|
---|
217 |
|
---|
218 | 2000/01/22: Harald Kornmayer
|
---|
219 |
|
---|
220 | * started with the development of a EventDisplay Utitliy.
|
---|
221 | Therefore I added the following files.
|
---|
222 |
|
---|
223 | meventdisp/EvtDispIncl.h
|
---|
224 | meventdisp/EvtDispLinkDef.h
|
---|
225 | meventdisp/MGFadcDisp.cc
|
---|
226 | meventdisp/MGFadcDisp.h
|
---|
227 | meventdisp/Makefile
|
---|
228 |
|
---|
229 | Also a few of the older files where slightly changed.
|
---|
230 | ./Makefile
|
---|
231 | ./Makefile.rules
|
---|
232 | mraw/MRawEvtData.
|
---|
233 |
|
---|
234 |
|
---|
235 | 2000/01/19: Thomas Bretz
|
---|
236 |
|
---|
237 | * mmc/*.hxx:
|
---|
238 | - changed include of MDefineTrigger.h back
|
---|
239 |
|
---|
240 |
|
---|
241 | 2000/01/19: Oscar Blanch
|
---|
242 |
|
---|
243 | * mmc/MTriggerDefine.h:
|
---|
244 | - added
|
---|
245 |
|
---|
246 |
|
---|
247 | 2000/01/18: Thomas Bretz
|
---|
248 |
|
---|
249 | * Makefile:
|
---|
250 | - mmc-library added
|
---|
251 |
|
---|
252 | * Makefile.conf.general:
|
---|
253 | - Added definition of __MARS__
|
---|
254 |
|
---|
255 | * Makefile.rules:
|
---|
256 | - Added definitions to rootcint
|
---|
257 |
|
---|
258 | * Oscar added the McFormat subdir of the Monte Carlo as mmc
|
---|
259 |
|
---|
260 | * mmc/MMcEvt.h:
|
---|
261 | - renamed to MMcEvt.hxx
|
---|
262 |
|
---|
263 | * mmc/*.hxx:
|
---|
264 | - added necessary defintions from MDefineTrigger.h
|
---|
265 |
|
---|
266 | * mmc/Makefile, mmc/McLinkDef.h, mmc/McIncl.h, mmc/readme.txt:
|
---|
267 | - added
|
---|
268 |
|
---|
269 | * mmc/LinkDef.h:
|
---|
270 | - removed
|
---|
271 |
|
---|
272 |
|
---|
273 | 2000/01/17: Thomas Bretz
|
---|
274 |
|
---|
275 | * Makefile:
|
---|
276 | - Exchanged explicit rules to make library by implicit ones
|
---|
277 | - The shared object works now. I exchanged the libraries with the object
|
---|
278 | files. But I don't know why the libraries don't work.
|
---|
279 |
|
---|
280 | * Makefile.conf.linux-gnu:
|
---|
281 | - replaced CC with gcc (instead of g++)
|
---|
282 |
|
---|
283 | * mdatacheck/DataCheckLinkDef.h:
|
---|
284 | - removed unused statements
|
---|
285 |
|
---|
286 | * mraw/RawLinkDef.h:
|
---|
287 | - added globals
|
---|
288 |
|
---|
289 | * mraw/MerppLinkDef.h:
|
---|
290 | - removed unused file
|
---|
291 |
|
---|
292 |
|
---|
293 | 2000/01/12: Thomas Bretz
|
---|
294 |
|
---|
295 | * MLinkDef.h, MIncl.h, marslogo.xpm, magiclogo.xpm:
|
---|
296 | - added
|
---|
297 |
|
---|
298 | * LinkDef.h:
|
---|
299 | - removed
|
---|
300 |
|
---|
301 | * Makefile:
|
---|
302 | - Added CINT, mrproper
|
---|
303 |
|
---|
304 | * mbase/Makefile, mraw/Makefile, mgui/Makefile, mdatacheck/Makefile:
|
---|
305 | - included makefile.general, Makefile.rules,
|
---|
306 | - removes corresponding lines
|
---|
307 |
|
---|
308 | * mdatacheck/MDumpEvtHeader.[h,cc], mdatacheck/MFillAdcSpect.[cc,h],
|
---|
309 | mdatacheck/MFillAdcSpect.[h,cc], mdatacheck/MGDisplayAdc.[cc,h],
|
---|
310 | mdatacheck/MHistsosAdc.[h,cc], mdatacheck.MShowSpect.[cc,h]
|
---|
311 | - changed include statements
|
---|
312 |
|
---|
313 | * mgui/MGDataCheckMain.[cc,h], mgui/MGMarsMain.[cc,h]
|
---|
314 | - changed include statements
|
---|
315 | - move enum from h to cc
|
---|
316 | - removed comma operator from delete statements (nonsense)
|
---|
317 |
|
---|
318 |
|
---|
319 | 2001/01/11: Harald Kornmayer
|
---|
320 |
|
---|
321 | * ./
|
---|
322 | readraw.cc, Makefile, Makefile.rules, LinkDef.h, MParList.cc, MReadTree.cc,
|
---|
323 | MReadTree.h, mbase/Makefile, mraw/Makefile
|
---|
324 | - small changes in this files. Not really critical.
|
---|
325 |
|
---|
326 | * mars.cc
|
---|
327 | - added the main file for the gui
|
---|
328 |
|
---|
329 | * mgui/
|
---|
330 | GuiIncl.h, MGMarsMain.cc, GuiLinkDef.h, MGMarsMain.h, MGDataCheckMain.cc,
|
---|
331 | Makefile, MGDataCheckMain.h
|
---|
332 | - added the subdir mgui and this files
|
---|
333 |
|
---|
334 | * mdatacheck/
|
---|
335 | DataCheckIncl.h, DataCheckLinkDef.h, MHistosAdc.cc, MHistosAdc.h,
|
---|
336 | MDumpEvtHeader.cc, MDumpEvtHeader.h, MShowSpect.cc, MShowSpect.h,
|
---|
337 | MFillAdcSpect.cc, MFillAdcSpect.h, MViewAdcSpectra.cc, MViewAdcSpectra.h,
|
---|
338 | MGDisplayAdc.cc, MGDisplayAdc.h, Makefile
|
---|
339 | - added the subdir mdatacheck and this files
|
---|
340 |
|
---|
341 |
|
---|
342 | 2000/12/28: Thomas Bretz
|
---|
343 |
|
---|
344 | * merpp.cc, MArray.cc, MArray.h, MArrayB.cc, MArrayB.h, MArrayS.cc,
|
---|
345 | MArrayS.h, MEvtLoop.cc, MEvtLoop.h, MInputStreamID.cc, MInputStreamID.h,
|
---|
346 | MParContainer.cc, MParContainer.h, MParList.cc, MParList.h, MReadTree.cc,
|
---|
347 | MTask.cc, MTask.h, MTaskList.cc, MTaskList.h, MTime.cc, MTime.h:
|
---|
348 | - Added changes some comments.
|
---|
349 |
|
---|
350 | * MLoopEvt.cc, MLoopEvt.h:
|
---|
351 | - Removed
|
---|
352 |
|
---|
353 |
|
---|
354 | 2000/12/22 - Thomas Bretz:
|
---|
355 |
|
---|
356 | * readraw.cc:
|
---|
357 | - changed some comments and the Root-Name of the program
|
---|
358 | - added check for the existance of the file
|
---|
359 | - changed name of numbers of entries from iEnt to nent
|
---|
360 |
|
---|
361 | * dohtml.C:
|
---|
362 | - changed title of converted macros
|
---|
363 |
|
---|
364 | * MRawEvtData.cc:
|
---|
365 | - added a commet in Draw()
|
---|
366 |
|
---|
367 | * MRawEvtPixelIter.[h,cc]:
|
---|
368 | - Added the comment header of the file
|
---|
369 | - removed inheritance from TIterator (not needed)
|
---|
370 | - some changes to get it work (the one in the repository was untested
|
---|
371 | and not working)
|
---|
372 | - changed calling style of iterator from do...while to while-loop
|
---|
373 | - changed some comments
|
---|
374 |
|
---|
375 | * MRawRunHeader.cc:
|
---|
376 | - added some comments
|
---|
377 |
|
---|
378 | * Changelog, News: added
|
---|
379 |
|
---|
380 | * test.C: removed
|
---|