Changeset 10638


Ignore:
Timestamp:
May 9, 2011, 10:44:12 PM (8 years ago)
Author:
tbretz
Message:
Updated with latest experiences installing FACT++ on Ubuntu 11.04 (natty)
File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/FACT++/MAINPAGE

    r10550 r10638  
    3636are extracted from subsequent calls to \b root-config.
    3737
    38 Hint: Sometimes installing root from packages doesn't work as
    39 expected (at least on my Ubuntu). It might be necessary to
    40 find some of the root packages with the libraries giving trouble
    41 and reinstall them after the root package was already installed.
    42 
    43 Remark: root 5.24 und root 5.26 seem to have issues. Although there
    44 are some X errors when starting, it seems to work quite nice with
    45 5.18/00b and 5.26/00e
    46 
    4738Running \b ./configure will take some time. It tries to really check
    4839carefully that everything needed is available on your system, so that you
     
    7061@subsection packages Required packages
    7162
    72 If you find a new package needed for installation please don't
    73 hesitate to report it, so that it can be added to the list below.
    74 
    75 Packages known to be needed to configure and compile FACT++
    76 
    77 <B>Dim:</B>
    78 - lesstif2, lesstif2-dev (Xm.h, needed to compile did)
    79 
    80 <B>Libraries:</B>
    81 - libreadline, libreadline-dev
    82 - boost, boost-dev (>=V1.40, all)
    83 - mysql++, mysql++-dev
    84 - libcfits, libcfitsio-dev
    85 - libccfits, libccfits-dev                                       
    86 
    87 <B>For GUI support:</B>
    88 - libqt4-core
     63The following section gives a list of packages which were necessary after
     64a fresh Ubuntu 11.04 installation. In addition to all the development
     65packages the corresponding package with the library is needed.
     66
     67<i>Required</i>
     68- subversion
     69- gcc
     70- g++
     71- make
     72- libreadline6-dev
     73- libcfitsio3-dev
     74- libccfits-dev
     75- libmysqlclient-dev
     76- libmysql++-dev
     77- libboost-all-dev
     78- libx11-dev
     79
     80<i>If you want 'did'</i>
     81- lesstif2-dev
     82
     83<i>To compile the gui</i>
    8984- libqt4-dev
    90 - root
    91 
    92 <B>Documentation:</B>
     85- root (see section about root, currently recommended versions 5.18/00b-5.26/00e)
     86
     87<i>To create your own documentation</i>
     88- graphviz
    9389- doxygen
    94 - graphviz
    9590- help2man
    96 - groff
    97 - ps2pdf
    98 
    99 <B>Only for maintainers:</B>
    100 - autoconf (automake, autotools-dev, m4)
     91
     92<i>For developers</i>
     93- autoconf
    10194- autoconf-archive
    102 - libtool (contains libtoolize
    103 - colorsvn (recommended)
    104 - colorgcc (recommended)
     95- libtool
    10596- qt4-designer
     97
     98<i>Some nice to have (FACT++)</i>
     99- colorsvn
     100- colorgcc
     101- colordiff
     102
     103<i>Some nice to have (system)</i>
     104- fte
     105- efte
     106- htop
     107
     108@section How to install root 5.26/00 on Ubuntu 11.04 (natty)
     109
     110- install gpp4.4, gcc4.4, g++4.4 (root does not compile with gcc4.5)
     111- make links to hidden X11 libraries:
     112<B><pre>
     113cd /usr/local
     114sudo ln -s x86_64-linux-gnu/libX* .
     115</pre></B>
     116- in the root source directory
     117<B><pre>
     118./configure --enable-qt --with-cc=gcc-4.4 --with-cxx=g++-4.4 --with-xrootd-opts=--syslibs=/usr/lib/x86_64-linux-gnu --prefix=/usr/local
     119</pre></B>
     120- \b make
     121- <b>sudo make install</b>
     122- pray
     123- don't forget to set LD_LIBRARY_PATH correctly before you try to start the fact gui
     124
    106125
    107126@section Demo Current demonstration programs
Note: See TracChangeset for help on using the changeset viewer.